Posts

Showing posts from August, 2013

Update metasploit in Backtrack 5R3 (8/2013)

When i update metasploit, i got many errors. After fixed all, i wrote some solution: If you get this error: $ svn up Updating '.': Authentication realm: =[ MSF must be updated via GitHub or a more recent msfupdate. See http://r-7.co/MSF-SVN for more]= Don`t answer any thing, do it:   cd /opt/metasploist   mv msf3 msf3_back   rm -rf msf3   git clone --depth=1 git://github.com/rapid7/metasploit-framework msf3 After git metasploit, update it. Before update, you should change ruby path to 1.9.3 (default is 1.9.2)      update-alternatives --install /usr/bin/ruby ruby /opt/metasploit/ruby/bin/ruby 400      update-alternatives --config ruby      Chose new ruby (/opt)      cd /opt/metasploit/msf3 Update now:      ./msfupte If you get error with pg install: Edit: /opt/metasploit/ruby/lib/ruby/1.9.1/i686-linux/rbconfig.rb  Change: CONFIG["LIBRUBYARG_STATIC"] = "-Wl,-R -Wl,$(libdir) -L$(libdir) -l$(RUBY_SO_NAME)-static" To: CONFIG["LIBRUBYARG_STATIC"] = "