Posts

Showing posts from November, 2014

Install GDB 7.8 support python 2 for PEDA

Now, i am using Ubuntu 14.04 LTS 64bit. But don`t have mirror for downgrade GDB. (Hanoilug mirror for 32bit only). So i must install GDB 7.8 support python2. First, install lib: #sudo apt-get install libncurses5-dev #apt-get install python2.7-dev texinfo Extrack gdb tar packet. cd #./configure --disable-werror --with-python=python2 #make #make install Then remove, check GDB version (Now ubuntu GDB is 7.7.1). If return 7.8 is ok, if not you can create symlink:  #cd /usr/bin #rm -rf gdb #ln -s /path/to/gdb-7.8/gdb/gdb gdb Install Peda anh using now :) Update: Now peda supported python3. :) ------------------------------------------------------------ Thanks for reading -------------------------------------------------------------------------- Security Research All my Lab: Linux Lab -- window and Cisco Lab to be continued - I will update more.