Posts

Showing posts from 2015

Text note for using ibus-unikey

First, you must set up (install and config ibus-unikey) in Unity. ibus-unikey is default install, but if not in your application can install by typing: apt-get install ibus-unikey. Then, go to "Text Enrty" to add Vietnamese - Unikey. To change between English and Vietnamese, using: Supper (Windows) + Space. Short entry for long time. ---------------------------------------------------------- Thanks for reading -------------------------------------------------------------------------- Security Research SecurityLab - Linux Lab -- Window and Cisco Lab to be continued - I will update more.

Change Gnome menu button to right and add more workspace

I my work, i offten use Windows. So i  need change Gnome button (minimize, close, maximum) from top left to top right. You can use Ubuntu Gnome tweak, but follow me. you shoud use dconf config. #apt-get install dconf-editor dconf-tool Type Alt + F2, type: dconf-editor It will open dconf Editor. Find: com.org.gnome.desktop.wm.preferences. Change button-layout to: :minimize,maximize,close Close it. Gnome will change. To use more work space in metacity: Find: com.org.gnome.metacity. Check in checkbox compositing-manager. To switch between workspace: Ctrl + Alt + Arrow key (Left, Right, Up, Down) ---------------------------------------------------------- Thanks for reading -------------------------------------------------------------------------- Security Research SecurityLab - Linux Lab -- Window and Cisco Lab to be continued - I will update more.

Install metasploit from github on Ubuntu

I need metasploit but download from www.rapid7.com too big, and i don`t need use pro version. So i chosed developer version from: https://github.com/rapid7/metasploit-framework.git Install dependency package: #apt-get install build-essential libreadline-dev libssl-dev libpq5 libpq-dev libreadline5 libsqlite3-dev libpcap-dev openjdk-7-jre subversion git-core autoconf postgresql pgadmin3 curl zlib1g-dev libxml2-dev libxslt1-dev vncviewer libyaml-dev ruby1.9.3 ruby-dev #gem install wirble sqlite3 bundler #curl -L https://raw.githubusercontent.com/wayneeseguin/rvm/master/binscripts/rvm-installer | bash -s stable --autolibs=enabled --ruby=1.9.3 #source /usr/local/rvm/scripts/rvm #rvm install ruby-2.1.5 #gem install rake -v '10.4.2' Clone from github: #git clone https://github.com/rapid7/metasploit-framework.git #bundle install Note: From metasploit 4.11, required ruby >= 2.1 #rvm list knows #rvm use 2.1 --default #rvm -v #chmod o+r /usr/local/rvm/gems/ruby-2.1.5/g

Fix Wrong sources.list entry or malformed file after install skype on Ubuntu 64bit

Today, after install skype (32bit) on Ubuntu 14.04 64 bit used gdedi, i have some error: After "apt-get update": Unable to find expected entry 'main/binary-i386sudo/Packages' in Release file (Wrong sources.list entry or malformed file) So i can not update my Ubuntu. You can fix it using this method: #dpkg --print-foreign-architectures You can get i386 i38 i386sudo ... Remove wrong architecture: #dpkg --remove-architecture i386 You can use: #sudo apt-get remove --purge `dpkg --get-selections | grep i386 | awk '{print $1}'` and #dpkg -l | grep i386 to find i386 packet to remove Then apt-get update now. ----------------------------------------------------------- Thanks for reading -------------------------------------------------------------------------- Security Research All my Lab: Linux Lab -- window and Cisco Lab to be continued - I will update more.